pavement

RAID3, Software, How to setup

From FreeBSDwiki
Jump to: navigation, search

In this example, we will set up a FreeBSD 6.2-RELEASE system with an 80GB SATA system drive at /dev/ad0, and 5 750GB SATA drives available at /dev/ad1 through /dev/ad5. Once we're done, we'll have those 5 750GB SATA drives in a RAID3 array (ie, four data drives plus one parity drive) with a total storage space of 2.8 terabytes. (The volume will only show 2.6T, but that's because of the 8% FreeBSD reserves by default for root's use.)

# graid3 load
# graid3 label myraid3array ad1 ad2 ad3 ad4 ad5

You just made a RAID3 array... yes, it really was that easy. Check it out:

# graid3 status
        Name        Status  Components
raid3/myraid3array  COMPLETE  ad1
                              ad2
                              ad3
                              ad4
                              ad5

Now we need to format it (note the -U argument, to enable Soft Updates on the new array):

# newfs -U /dev/raid3/myraid3array

You'll get several pages of cluster IDs scrolling by extremely rapidly at this point. On the example 5x750GB array we're discussing here, this step took about 90 seconds and scrolled several thousand lines.

With the array formatted, now we can mount it:

# mkdir /mnt/myraid3array
# mount /dev/raid3/myraid3array /mnt/myraid3array

And we're done - we now have a failure-tolerant array available!

# df -h /mnt/myraid3array
Filesystem                 Size    Used   Avail   Capacity  Mounted on
/dev/raid3/myraid3array    2.6T    12K    2.6T    0%        /mnt/myraid3array

If you want to mount your new array automatically on boot, just add an entry to /etc/fstab, and add geom_raid3_load="YES" to /boot/loader.conf to make sure that the RAID3 module will load at boot time before filesystems are mounted. (The loader.conf entry may not be strictly necessary under all installations, but can't ever hurt.) You're done!

Personal tools